现在的位置: 首页 > 网络 > 正文

CCNP培训重点知识点

2012年06月30日 网络 ⁄ 共 22846字 ⁄ 字号 暂无评论

一:路由器密码恢复过程,交换机密码恢复过程
首先需要把串口电缆的一段插在设备背面的Console口中,另一端在普通电脑的串口里。当路由器或者交换机加电后,操作系统使用“超级终端”程序。

1.启动路由器并且执行一个中断。

当路由器重新启动时,按下电脑的Ctrl+Break 键,中断路由器启动。

2.修改配置寄存器。

2600系列,命令是 Config-register 0x2142

2500系列,命令是 o/r 0x2142

3.重载路由器并进入特权模式。

2600系列:输入reset

2500系列:输入I

重载,会询问是否要使用设置模式,回答No,按回车进入用户模式,输入Enable命令,进入特权模式。

4.查看并修改配置。

需要将startup-config复制为running-config文件。

命令:copy startup-config running-config。

再用enable secret设置加密口令。

configure terminal

enable secret(password)

5.重设配置寄存器并重载路由器。

修改口令之后,一定要使用config-register 将配置寄存器设置回默认值config-register 0x2102,最后保存配置copy running-config

startup-config 并重载。路由器,口令恢复结束。

@@注意第二步跟第五步中的命令,不可颠倒顺序。
二:如何灌装IOS
IOS备份
1·安装TFTP服务器
2·查看路由器的IOS: show flash
3·查看路由器的E0端口配置是否和你的网卡是一个网段:192.168.3.*
4·copy flash tftp
弹出的要求原文件是 show flash 演示的文件名。
IP地址要设置为你的网卡IP地址(TFTP服务器的IP地址)
目的文件名,随意输入,最好自己名字,便于记忆
IOS灌装
1·安装TFTP服务器
2·查看路由器的IOS: show flash
3·修改路由器的寄存值为0x2101: confreg 0x2101
4·保存配置
5·重启
6·查看以太口E0端口配置是否和你的网卡是一个网段:192.168.3.*
7·把备份的IOS重新灌装到路由器上: copy tftp flash
8·弹出的要求原文件是 你上一个试验保存的文件名(自己名字)
IP地址要设置为你的网卡IP地址(TFTP服务器的IP地址)
目的文件名,随意输入,建议是CISCO
9·重启机器,改回寄存值
三:线缆中568A 568B的标准线序是什么

详细的568A和568B线序

568A:白绿 | 绿 | 白橙 | 蓝 | 白蓝 | 橙 | 白棕 | 棕

568B:白橙 | 橙 | 白绿 | 蓝 | 白蓝 | 绿 | 白棕 | 棕

直线:用于不同设备之间互连(交换机-PC)

568B-568B

反线:用于同种设备之间互连(PC-PC,交换机-交换机)

568A-568B
四:ip地址的划分思路

ip分三类

1.A类IP地址

一个A类IP地址是指,在IP地址的四段号码中,第一段号码为网络号码,剩下的三段号码为本地计算机的号码。如果用二进制表示IP地址的话,A类IP地址就由1字节的网络地址和3字节主机地址组成,网络地址的最高位必须是“0”。A类IP地址中网络的标识长度为7位,主机标识的长度为24位,A类网络地址数量较少,可以用于主机数达1600多万台的大型网络。

2.B类IP地址

一个B类IP地址是指,在IP地址的四段号码中,前两段号码为网络号码,剩下的两段号码为本地计算机的号码。如果用二进制表示IP地址的话,B类IP地址就由2字节的网络地址和2字节主机地址组成,网络地址的最高位必须是“10”。B类IP地址中网络的标识长度为14位,主机标识的长度为16位,B类网络地址适用于中等规模规模的网络,每个网络所能容纳的计算机数为6万多台。

3.C类IP地址

一个C类IP地址是指,在IP地址的四段号码中,前三段号码为网络号码,剩下的一段号码为本地计算机的号码。如果用二进制表示IP地址的话,C类IP地址就由3字节的网络地址和1字节主机地址组成,网络地址的最高位必须是“110”。C类IP地址中网络的标识长度为21位,主机标识的长度为8位,C类网络地址数量较多,适用于小规模的局域网络,每个网络最多只能包含254台计算机。

除了上面三种类型的IP地址外,还有几种特殊类型的IP地址,TCP/IP协议规定,凡IP地址中的第一个字节以“lll0”开始的地址都叫多点广播地址。因此,任何第一个字节大于223小于240的IP地址是多点广播地址;IP地址中的每一个字节都为0的地址(“0.0.0.0”)对应于当前主机;IP地址中的每一个字节都为1的IP地址(“255.255.255.255”)是当前子网的广播地址;IP地址中凡是以“llll0”的地址都留着将来作为特殊用途使用;IP地址中不能以十进制“127”作为开头,27.1.1.1用于回路测试,同时网络ID的第一个6位组也不能全置为“0”,全“0”表示本地网络。
五:有类路由和无类路由最大区别
有类的路由不会识别子网的信息,如宣告10.0.1.0/24 172.16.1.0/22 192.168.1.64/28 路由表中只会识别A类10.0.0.0/8,B类172.16.0.0/16 C类192.168.1.0/24 无类的路由协议不会根据A B C类来识别,根据子网掩码的长度来区分网段,所以说无类的路由协议都可以不支持路由自动汇总有类的路由自然也就不支持VLSM 无类的路由就可以支持VLSM IP路由协议可以被分为两大类,一类是有类的,另一类是无类的。IP Classful RIP v1, IGRP ,EGP IP Classless RIP v2 ,EIGRP, OSPF, IS-IS, BGP 有类的路由协议只会传送网络前缀(网络地址),但是不会包含子网掩码。当它传送更新时,它首先检查直接连接的网络是否和发送更新的网络属于同一个大一点的子网,如果是的,那么它会继续检查它们的子网掩码是否相等,如果不等,那么更新信息会被丢弃而不会被广播。当路由器A发送更新给路由器B时,它遵循下列几个步骤: 1. 路由器A检查192.168.1.0/24是否和192.168.2.0/30(更新传向过的网络)属于同一个大一点的网路。
2. 答案是是的,所以路由器A比较它们的子网掩码192.168.1.0/24和192.168.2.0/30。
3. 因为它们有两个不同的子网掩码,所以信息被丢弃。这就是为什么有类路由协议不支持VLSM(可变长子网掩码) 无类路由协议传输网络前缀(网络地址)的同时也会传输子网掩码,所以它支持VLSM有类地址:早期的ip地址没有子网掩码,所有的地址都属于相应的主类网,距离矢量路由协议如RIP1,igrp属于有类的路由协议,它所不能从邻居那里学到子网,所有关于子网的路由被学到后自动转为相应的主类网。譬如182.16.1.0就会变成B类地址的主类网182.16.0.0。 无类地址:根据可变长度的子网掩码划分不同的网络。譬如182.16.1.101,有类的话所在子网网段为182.16.0.0,子网掩码255.255.0.0,现在将子网掩码改为255.255.255.252的30位掩码,所在子网网段就是182.16.1.100。支持可变长度子网掩码的路由协议有RIP2,OSPF以及EIGRP。
五:如果在冗余交换网络环境没有SPT会发生什么?
首先冗余和负载分担是两个概念,冗余和备份在一起,单纯的冗余技术不一定实现负载分担,负载分担是靠冗余的。
STP协议生来就是为了冗余存在的。单纯树型无法提供足够的可靠性,由此我们引入额外链路,这就是环路的问题。STP为IEEE802.1D标准,它内部只有一个stp tree,因此必然有一条blocking,不会转发数据,只有另外一条出现问题才会用这条。
Cisco对stp做了改进。他使得每个vlan都运行一颗stp tree,这样第一条链路可以为vlan1 2 3服务,对vlan4 5 6blocking,第二条链路可以为vlan4 5 6forwarding,对vlan1 2 3 关闭,无形中实现了链路的冗余,负载分担,这种技术就是PVST+
STP将端口定义5种状态,分别为blocking listening learning forwarding disabling。想要从blocking切换至forwarding状态,必须经过50秒的周期,20秒的blocking状态下,如果没有检测到邻居发的bpdu包,则进入listening这时会选举root bridge,designate port root port,15秒后进入leaning,这个状态下可以学习MAC地址,为最后的forwarding做准备,同样是15秒。
RSTP(802.1w)的出现解决了延迟的问题。他的收敛速度可快,当然cisco也针对这种技术提出了RPVST+技术。Pstp在stp基础上额外定义了两种port role,分别是alternate与backup,另外重新规定port state,分别为discarding learning forwarding。
Stp的最大失败在于它混淆了port role与port state,在rstp上,这样的问题不存在
RSTP还定义两个新的概念:edge port与link type,如果是edge port表明下面接的只能是主机,环路是不存在的。所以我们可以直接将discarding切换到forwarding状态。类似于stp中的port fast技术。而link type定义了这条链路是点对点的还是shared,如果在pt-pt环境下,我们可以做快速切换了。
MSTP(802.1s)
Stp和rstp都是采用一个stp tree,负载分担不可实现。而cisco的pvst+和rpvst+采用了每个vlan一棵生成树,虽然实现了负载分担,但是会占用cpu时间,这也是MSTP(802.1s)产生的原因。
MSTP可以将多个vlan的生成树映射为一个实例,我们不需要那么多的生成树,只需要按照冗余链路的条数来得出需要几棵生成树。MSTP是基于RSTP的,没有RSTP,MSTP是无法运行的。PVST+与RPVST+模式下,交换机可以支持128个STP instance MSTP模式下,交换机支持65个MST实例,当然每个实例中的vlan数目是无限的。
六:vlan技术的作用,trunk的原理是什么,trunk的两种封装是什么
VLAN(Virtual Local Area Network)即虚拟局域网,是一种通过将局域网内的设备逻辑地而不是物理地划分成一个个网段从而实现虚拟工作组的新兴技术。IEEE于1999年颁布了用以标准化VLAN实现方案的802.1Q协议标准草案。
VLAN技术允许网络管理者将一个物理的LAN逻辑地划分成不同的广播域(或称虚拟LAN,即VLAN),每一个VLAN都包含一组有着相同需求的计算机工作站,与物理上形成的LAN有着相同的属性。但由于它是逻辑地而不是物理地划分,所以同一个VLAN内的各个工作站无须被放置在同一个物理空间里,即这些工作站不一定属于同一个物理LAN网段。一个VLAN内部的广播和单播流量都不会转发到其他VLAN中,即使是两台计算机有着同样的网段,但是它们却没有相同的VLAN号,它们各自的广播流也不会相互转发,从而有助于控制流量、减少设备投资、简化网络管理、提高网络的安全性。
VLAN是为解决以太网的广播问题和安全性而提出的,它在以太网帧的基础上增加了VLAN头,用VLAN ID把用户划分为更小的工作组,限制不同工作组间的用户二层互访,每个工作组就是一个虚拟局域网。虚拟局域网的好处是可以限制广播范围,并能够形成虚拟工作组,动态管理网络。
既然VLAN隔离了广播风暴,同时也隔离了各个不同的VLAN之间的通讯,所以不同的VLAN之间的通讯是需要有路由来完成的。TRUNK是端口汇聚的意思,就是通过配置软件的设置,将2个或多个物理端口组合在一起成为一条逻辑的路径从而增加在交换机和网络节点之间的带宽,将属于这几个端口的带宽合并,给端口提供一个几倍于独立端口的独享的高带宽。Trunk是一种封装技术,它是一条点到点的链路,链路的两端可以都是交换机,也可以是交换机和路由器,还可以是主机和交换机或路由器。基于端口汇聚(Trunk)功能,允许交换机与交换机、交换机与路由器、主机与交换机或路由器之间通过两个或多个端口并行连接同时传输以提供更高带宽、更大吞吐量,大幅度提供整个网络能力。

一般情况下,在没有使用TRUNK时,大家都知道,百兆以太网的双绞线的这种传输介质特性决定在两个互连的普通10/100交换机的带宽仅为100M,如果是采用的全双工模式的话,则传输的最大带宽可以达到最大200M,这样就形成了网络主干和服务器瓶颈。要达到更高的数据传输率,则需要更换传输媒介,使用千兆光纤或升级成为千兆以太网,这样虽能在带宽上能够达到千兆,但成本却非常昂贵(可能连交换机也需要一块换掉),更本不适合低成本的中小企业和学校使用。如果使用TRUNK技术,把四个端口通过捆绑在一起来达到800M带宽,这样可较好的解决了成本和性能的矛盾。
Trunk的具体运用:
1、TRUNK功能用于与服务器相联,给服务器提供独享的高带宽。
 2、TRUNK功能用于交换机之间的级联,通过牺牲端口数来给交换机之间的数据交换提供捆绑的高带宽,提高网络速度,突破网络瓶颈,进而大幅提高网络性能。
3、Trunk可以提供负载均衡能力以及系统容错。由于Trunk实时平衡各个交换机端口和服务器接口的流量,一旦某个端口出现故障,它会自动把故障端口从Trunk组中撤消,进而重新分配各个Trunk端口的流量,从而实现系统容错。
封装方式有:两种方式,IEEE是802.1q协议,cisco专有isl
七:简述pvst和mst的原理
PVST的高级版本就是MST,MST可以更好的流量均衡,比如PVST说的是每一个VLAN一棵树,但是这样的话会有大量的数据协议报对带宽照成影响,而MST可以多个VLAN对应一个实例,每个实例一棵树,这样对带宽更好,还有一点就是MST结合了RSTP的快速特性,它和RSTP用刀了在CST和PVST中的数据中没有用的一些FLAG位,这样在1秒内,MST RSTP的收敛就可以完成。
八:距离矢量和链路状态协议分类?他们之间的最大的区别是什么,为什么eigrp是一个混合型的路由协议?
距离矢量路由协议Distance vector routing protocol,是根据距离矢量(跳数hop)来进行路由选择的一个确定最佳路由的方法,比如RIP协议就是一种距离向量协议。链路状态路由协议Link State Routing Protocol则是根据带宽、延迟等指标综合考虑而得到一个权值,再根据权值确定最佳路由的方法,比如ospf就是一类链路状态协议。运行距离矢量路由协议的路由器,会将所有它知道的路由信息与邻居共享,但是只与直连邻居共享!

所有距离矢量路由协议均使用Bellman-Ford(Ford-Fulkerson)算法,容易产生路由环路(loop)和计数到无穷大(counting to infinity)的问题。因此它们必须结合一些防环机制:
split-horizon
route poisoning
poison reverse
hold-down timer
trigger updates
同时由于每台路由器都必须在将从邻居学到的路由转发给其它路由器之前,运行路由算法,所以网络的规模越大,其收敛速度越慢。运行链路状态路由协议的路由器,只将它所直连的链路状态与邻居共享,这个邻居是指一个域内(domain),或一个区域内(area)的所有路由器!链路状态路由协议均使用了强健的SPF算法,如OSPF的dijkstra,不易产生路由环路,或是一些错误的路由信息。路由器在转发链路状态包时(描述链路状态、拓扑变化的包),没必要首先进行路由运算,再给邻居进行发送,从而加快了网络的收敛速度。距离矢量路由协议,更新的是“路由条目”!一条重要的链路如果发生变化,意味着需通告多条涉及到的路由条目!每个路由器的路由表变化都需要邻居来通告,距离矢量路由协议发送周期性更新、完整路由表更新(periodic & full)。链路状态路由协议,更新的是“拓扑”!每台路由器上都有完全相同的拓扑,他们各自分别进行SPF算法,计算出路由条目!一条重要链路的变化,不必再发送所有被波及的路由条目,只需发送一条链路通告,告知其它路由器本链路发生故障即可。其它路由器会根据链路状态,改变自已的拓扑数据库,重新计算路由条目。每个路由器都独立的计算自己的最佳路由,区别于距离矢量协议中的由邻居通告。
八:VTP修剪是咋回事?简述vtp三种模式的功能
VTP修剪是思科VTP功能。它允许网络上的开关来动态添加或删除一个有效的交换网络的VLAN为一条主干道。在某些情况下,VTP可以创建不必要的交通。未知的单播和广播的VLAN充斥在整个VLAN。 VTP修剪功能有助于消除或修剪这个VLAN的不必要的交通。
服务器(server) 它是Catalyst交换机默认的模式,在server模式中能在VTP域中创建、添加或删除VLAN。改动VTP信息也必须在server模式下,在server模式下,对交换机所做的任何改动都将通告到整个VTP域中。在server模式下,VLAN配置保存在NVRAM中。功能:提供、学习、转发
客户机(client) 从VTP服务器中接收信息,同时它也发送和接收更新。但不能做任何改动。注意在client模式下它将学习新的信息,但不会将学到的VTP配置信息保存到NVRAM中,断电后就没有配置信息了。功能:只是学习及转发VTP信息。
透明(Transparent)在Transparent模式下,交换机并不参与VTP域的工作,也不与其他交换机共享其VLAN数据库,但它们仍然将通过任何已经配置好的中继链路转发VTP通告。这些交换机可以添加或删除VLAN,因为它们保持了自己的数据库——相对其它的交换机来说,它们处于保密状态。在Transparent模式下,尽管VLAN数据库被保存在NVRAM中,但实际上只是在本地有效。设置Transparent模式的目的:允许远程交换机从VTP服务器接收VLAN数据库信息,而这个VTP服务器是通过没有参与同一个VLAN分配的交换机进行配置的。它是最好的模式状态。功能:转发
九:为什么二层环路比三层环路危害大?为什么交换比路由快?
二层的环路通常都是冗余链路造成的,没有冗余链路就不存在环路。
三层的环路通常指的是路由环路,是由于启用路由协议不当造成的,比如矢量距离的路由协议(这里只说RIP),即使没有冗余链路,也有可能造成环路。
十:简述rip计时器?什么是水平分割?
水平分割(split horizon)是一种避免路由环的出现和加快路由汇聚的技术。由于路由器可能收到它自己发送的路由信息,而这种信息是无用的,水平分割技术不反向通告任何从终端收到的路由更新信息,而只通告那些不会由于计数到无穷而清除的路由。
  水平分割法的规则和原理是:路由器从某个接口接收到的更新信息不允许再从这个接口发回去。
  水平分割的优点:1,能够阻止路由环路的产生。2,减少路由器更新信息占用的链路带宽资源。
十一:ripv1和ripv2的区别
1.RIPv1是有类路由协议,RIPv2是无类路由协议
2.RIPv1不能支持VLSM,RIPv2可以支持VLSM
3.RIPv1没有认证的功能,RIPv2可以支持认证,并且有明文和MD5两种认证
4.RIPv1没有手工汇总的功能,RIPv2可以在关闭自动汇总的前提下,进行手工汇总
5.RIPv1是广播更新,RIPv2是组播更新,
6.RIPv1对路由没有标记的功能,RIPv2可以对路由打标记(tag),用于过滤和做策略
7.RIPv1发送的updata最多可以携带25条路由条目,RIPv2在有认证的情况下最多只能携带24条路由
8.RIPv1发送的updata包里面没有next-hop属性,RIPv2有next-hop属性,可以用与路由更新的重定。
十二:边界路由器
 网络边界的边缘或末点的路由器,提供了对外界网络的基本的安全保护,或者从缺乏网络控制的区域进入到专用网络区域。
十三:简述EIGRP的特点
EIGRP:Enhanced Interior Gateway Routing Protocol 即 增强网关内部路由线路协议。也翻译为加强型内部网关路由协议。 EIGRP是Cisco公司的私有协议。Cisco公司是该协议的发明者和唯一具备该协议解释和修改权的厂商。 EIGRP结合了链路状态和距离矢量型路由选择协议的Cisco专用协议,采用弥散修正算法(DUAL)来实现快速收敛,可以不发送定期的路由更新信息以减少带宽的占用,支持Appletalk、IP、Novell和NetWare等多种网络层协议。链路状态包(Link-State Packet,LSP)的转发是不依靠路由计算的,所以大型网络可以较为快速的进行收敛.它只宣告链路和链路状态,而不宣告路由,所以即使链路发生了变化,不会引起该链路的路由被宣告.但是链路状态路由协议使用的是Dijkstra算法,该算法比较复杂,并且较占CPU和内存资源和其他路由协议单独计算路由相比,链路状态路由协议采用种扩散计算(diffusingcomputations ),通过多个路由器并行的记性路由计算,这样就可以在无环路产生的情况下快速的收敛.
十四:eigrp的hello包多长时间发一次,里面都有什么信息?
EIGRP的hello时间在T1一下的线路是60s,在T1以上的线路是5s,而它的保持时间(hold timer)是hello时间的3倍。hello时间和保持时间不一致,也可以形成邻居关系,但是可能会出现一些问题,如:一边的hello时间大于另一边的保持时间这种情况。这种情况下,EIGRP的邻居关系现实为:up. down.up. down这样会断断续续的。EIGRP的hello时间不同不影响EIGRP建立邻居关系。
十五:eigrp的特点
EIGRP为增强的内部网关路由协议,是cisco的专有协议。
EIGRP的一般管理距离为90(interior eigrp),汇总的管理距离为5(summary eigrp),从外部分发进来的为170(exterior eigrp);协议号为88。
EIGRP是一个Advanced distance vector;能够Rapid convergence;是100% loop-free classless routing;是一个支持非等价负载均衡的路由协议(默认4条最大6条);以组播(224.0.0.10)或单播进行更新。
缺省使用总带宽的50%,可用“bandwidth-percent eigrp”更改百分比。
EIGRP是非周期性更新,只有在拓扑有变化时才对变化的东西进行增量更新。并且只针对变化影响到的路由器进行更新(增量更新)。
运行EIGIP的接口必须从他的直连的邻居处获得更新。
由于EIGRP是一个为Adverance distance vector,具有distance vector的边界自动汇总的特性所以在配置时要“no auto”
DUAL算法中:Feasible distance(FD):可行性距离,是自己到目标的距离Advertised distance(AD):通告给你路由信息的邻居到目标的距离
Sussessor:(S)即最佳路径Feasible sussessor:(FS):即次优路径。
EIGRP的5种包:
hello:建立邻接关系,keeplive作用(组播)
query:向邻居查找路由信息(组播)
reply:对邻居的query查找进行回应(单播)
update:以增量的方式发送路由更新(组播或单播)
ack:对可靠包的确认(单播)
其中query,reply,update为可靠包(即必须得到ACK回应);hello包和ack包为不可靠包。
EIGRP的度量值可以基于带宽、延时、负载、可靠性、MTU,缺省仅使用带宽和延时。其metric计算方式为: Metric = [K1 x BW + ((K2 x BW) / (256 ? load)) + K3 x delay]
By default: K1 = 1, K2 = 0, K3 = 1, K4 = 0, K5 = 0
metric=[delay+107/BW]*256 “dely,mtu等”都可用sh int显示。
收敛过程
1). 邻居建立的条件:邻接路由器之间的hello包中只要5个K值和AS号相互间相同;则建立邻接关系。
2). EIGRP的hello包间隔时间:大于T1线路(1.544M/bps)或者是点对点线路则hello间隔为5秒;小于等于T1线路时hello包的间隔为60秒。
3). 再次收到hello包之前的保持时间为:hello包时间间隔的3倍。
4). 注意:EIGRP的hello包只能通过主地址进行传送,辅助地址不能传送hello包(只有RIP可以)。
5). 收敛过程
EIGRP的可靠传输机制(RTP):与HELLO包区分开来:
(1)当运行EIGRP的路由器向邻居发送了一个可靠包后(query,reply,update),因为可靠包只有得到确认后才会进行下一个可靠包的传输,所以如果在平均回程时间(即去往目标邻居加回来的时间之和)内没有收到ACK确认包则其会以单播方式重发一次可靠包,如果在16次后还没有收到则会宣告这个邻居无效。
(2)RTP表示可靠传输协议;RTO表示重传超时(原来传送失败后,以单播重传的等待确认报文的时间);SRTT表示平均回程时间(单位为毫秒ms);uptime表示邻居关系建立时间;Q cnt表示列队计数;seq num表示序列号(被更新一次就加1)
(3)可靠包只有得到确认后才会进行下一个可靠包的传输,典型的就是:“发出多少个query包就要收回多少个reply,否则不进行下一步”(当然,这也会带来问题)
二、 EIGRP常用命令及排错
基本配置:router eigrp AS号 同一区域的AS号必须相同
network ip地址 反码 反码只能精确匹配到子网掩码相同

EIGRP的路由汇总:在汇总后会在汇总的路由器的路由表中自动生成一条
......vir null0的条目,null0表示“垃圾通”;在汇总后其使用汇总中的最小metric作为其汇总后的metric;配置命令在接口下:ip summa eigrp as号 ip sm

EIGRP验证:
key chain jiang
key 1
key-string cisco
!
interface Serial0
ip address 192.168.2.253 255.255.255.252
ip authentication key-chain eigrp 100 jiang
ip authentication mode eigrp 100 md5 md5加密

不等价负载均衡的设置:
可关闭一在路由表中的接口,使备用生效,查看metric值; router eigp下:variance 比例值 比例值=两条线路的metric相除,是大的除以小的,有小数点则进位加1。

默认路由配置:
EIGRP不支持默认路由(0.0.0.0 255.255.255.255),其只支持默认网络(主网络号)(当然可以用重分发静态路由),配置完后,区域内的路由器都会学到这条默认网络,将会在其自己的路由表中建立一条指向默认网关的最优路径。配置为:在全局模式下:②ip default-network 主网络号,然后:ip route 主网络号掩码下一跳,然后在router eigrp里使用:net 主网络号无反码

EIGRP相关的show命令:
Show running-config
Show ip route
Show ip route eigrp ;仅显示EIGRP路由
Show ip eigrp interface ;显示该接口的对等体信息
Show ip eigrp neighbors ;显示所有的EIGRP邻居及其信息
Show ip eigrp topology ;显示EIGRP拓扑结构表的内容
Show ip eigrp traffic ;显示EIGRP路由统计的归纳
Show ip eigrp events ;显示最近的EIGRP协议事件记录

EIGRP相关的debug命令:
Debug ip eigrp as号
Debug ip eigrp neighbor
Debug ip eigrp notifications
Debug ip eigrp summary
Debug ip eigrp

常见的EIGRP故障:相邻关系、缺省网关等的丢失、老版本IOS的路由、stuck in active。

处理EIGRP故障时,先用show ip eigrp neighbors查看所有相邻路由器,然后再用show ip route eigrp查看路由器的路由表,再用show ip eigrp topology查看路由器的拓扑结构表,也可用show ip eigrp traffic查看路由更新是否被发送。

网络断断续续:
邻居有时在有时神秘失踪可能是SIA的问题,可通过日志,查看到“DUAL ....SIA....”

如果网络规模比较小,路由器和交换机只有几十台或100之内,建议使用EIGRP协议
如果你总部与子站点间有多条线路,可以考虑使用EIGRP进行负载平衡。EIGRP有着非常出色的负载平衡效果。
EIGRP网络工程实例
1. 工程实例一:
如下是深圳市某大型单位的一个网络拓扑图,其中有cisco7513...................等cisco路由器与交换机约120台左右。网络覆盖广东省大部分地区,如下是在ciscowork上的拓扑图

Cisco7513上的配置为:
Sh ru
Current configuration : 8511 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname cisco_7513
!
enable secret 5 $1$ycCM$6GK24Ndfdfdsfdfd9Q1
!
!
!
ip subnet-zero
no ip domain-lookup
!
ip multicast-routing
ip cef
……………………………….
router eigrp 1
redistribute static
network 192.168.0.0
network 172.16.10.0
no auto-summary
no eigrp log-neighbor-changes

cisco4500上的配置:
sh ru
Current configuration:
!
version 11.1
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname Cisco4500
!
enable secret 5 $1$l.Uf$XDRSQb/gdfdffdf8DiRoW1
!
username admin
ip subnet-zero
no ip domain-lookup
!
router eigrp 1
redistribute static
network 192.168.0.0
network 192.168.10.0
network 172.16.10.0
no auto-summary
其它一些路由器上的配置:如25xx 36xx
outer eigrp 1
network 192.168.0.0
network 172.16.10.0
neighbor 10.10.176.60
no auto-summary
2. 工程实例二
广州一家公司的总部位于天河,分公司遍及全国各地和香港,大约有20家分公司,现在通过一家ISP建立了一个VPN互连网络,路由协议采用EIGRP.其中一个路由器配置为:

router eigrp 1
redistribute static metric 100 100 255 1 1500 route-map static2eigrp
network 192.168.254.0 0.0.0.255
network 192.168.255.0 0.0.0.255
network 192.168.0.0
distribute-list prefix 111 out vpn40101
distribute-list prefix 112 out vpn40102
distribute-list prefix 111 out vpn40201 这里的vpn40201指的是IP tunnel的VPN遂道接口名称
distribute-list prefix 112 out vpn40202
distribute-list prefix 111 out vpn40301
distribute-list prefix 112 out vpn40302
distribute-list prefix 111 out vpn40501
distribute-list prefix 112 out vpn40502
no auto-summary
no eigrp log-neighbor-changes
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0

............

no ip http server
!
!
ip prefix-list 111 description "Deny ERP"
ip prefix-list 111 seq 5 permit 0.0.0.0/0 le 31
!
ip prefix-list 112 description "Permit ERP"
ip prefix-list 112 seq 5 permit 0.0.0.0/0 ge 32

access-list 2 permit 192.168.100.0 0.0.0.255
access-list 2 permit 192.168.101.0 0.0.0.255

route-map static2eigrp permit 10
match ip address 2
EIGRP拓扑表如下:
sh ip eigrp topology:

IP-EIGRP Topology Table for AS(1)/ID(x.x.x.254)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 192.168.254.0/30, 2 successors, FD is 310044416
via 192.168.255.13 (310044416/297244416), vpn40101
via 192.168.255.21 (310044416/297244416), vpn40201
P 192.168.255.0/30, 2 successors, FD is 310044416
via 192.168.255.13 (310044416/297244416), vpn40101
via 192.168.255.21 (310044416/297244416), vpn40201
P 192.168.254.4/30, 1 successors, FD is 297244416
via Connected, vpn40302
P 192.168.255.4/30, 1 successors, FD is 297244416
via Connected, vpn40301
P 192.168.254.8/30, 2 successors, FD is 310044416
via 192.168.255.5 (310044416/297244416), vpn40301
via 192.168.255.13 (310044416/297244416), vpn40101
P 192.168.255.8/30, 2 successors, FD is 310044416
via 192.168.255.5 (310044416/297244416), vpn40301
via 192.168.255.13 (310044416/297244416), vpn40101
P 192.168.254.12/30, 1 successors, FD is 297244416
via Connected, vpn40102
P 192.168.255.12/30, 1 successors, FD is 297244416
via Connected, vpn40101
P 192.168.254.16/30, 2 successors, FD is 310044416
via 192.168.255.5 (310044416/297244416), vpn40301
via 192.168.255.21 (310044416/297244416), vpn40201
P 192.168.255.16/30, 2 successors, FD is 310044416
via 192.168.255.5 (310044416/297244416), vpn40301
via 192.168.255.21 (310044416/297244416), vpn40201
P 192.168.254.20/30, 1 successors, FD is 297244416
via Connected, vpn40202
P 192.168.255.20/30, 1 successors, FD is 297244416
via Connected, vpn40201
P 192.168.254.24/30, 2 successors, FD is 310044416
via 192.168.255.5 (310044416/297244416), vpn40301
via 192.168.255.30 (310044416/297244416), vpn40501
P 192.168.255.24/30, 2 successors, FD is 310044416
via 192.168.255.5 (310044416/297244416), vpn40301
via 192.168.255.30 (310044416/297244416), vpn40501
P 192.168.254.28/30, 1 successors, FD is 297244416
via Connected, vpn40502
P 192.168.255.28/30, 1 successors, FD is 297244416
via Connected, vpn40501
P 192.168.9.0/24, 1 successors, FD is 297270016
via 192.168.255.30 (297270016/25625600), vpn40501

P 192.168.100.0/24, 1 successors, FD is 25625600
via Rstatic (25625600/0)
P 192.168.101.0/24, 1 successors, FD is 25625600
via Rstatic (25625600/0)
.............
十九:eigrp是个什么样的重传机制
如果Hold Timer所定义的时间内,收不到对方的HELLO包,邻居关系就会Reset

不稳定的网络:
EIGRP对于可靠传输报文,有必需的确认机制,
如果没有收到对方的确认,那么可靠传输包就会发生重传,极限是16次,
如果达到极限,都没有收到对方的确认,那么就RTO,Reset。
(RTO:Retransmission TimeOut.)

因为EIGRP的是windows size of one (stop-and-wait mechanism)
所以如果在对一组邻居,进行组播的路由更新时,
有个别路由器响应特别慢,
可能导致整个EIGRP网络的收敛效率低下.

解决方案是:
对正常的大部分路由器做组播更新,
对特别慢的路由器,单独进行单播更新.
SRTT(smooth round-trip time)平均回程时间,是衡量路由器发送EIGRP报文到邻居和从邻居收到对于该报文的确认为止,所花费的平均时间,以毫秒(ms)为单位。
RTO(retransmission timeout)重传超时,当EIGRP报文以多播之式传出之后,经过RTO时间周期后仍未收到邻居的ACK应答,接下来的报文会以单播(unicast)方式重新传输,所以叫重传超时时间。
Q(queue count)队列计数,当EIGRP更新、查询或是应答消息向邻居发送出去后,同样的一份报文的拷贝将会被放进队列中,一旦RTO超时后仍未收到对方的应答,这份拷贝就会被发送出去。
 Seq(sequence number)序号,记录了上次从邻居收到的更新、查询或应答消息的序号。
二十:eigrp的sia的形成过程,解决办法?
EX:假如1.1.1.1出现故障,无法访问.R1从S1/1,Fa0/0发送替代路由请求,R2收到请求后,查询自己的路由表,发现没有,它就向R3发出一个请求,如果S1/1--S1/0这条链路出现问题,R2发出的请求R3并没有收到,1.5分钟后,R1开始发送SIA查询,R2收到这个查询后,回复一个SIA应答,此时,R1通过这个回复知道R1与R2的链路是正常的.同理:R3收到R1的请求后,发给R2,如果R2太忙,无法进行及时回复,1.5分钟后,R1开始发送SIA查询,R3收到这个查询后,回复一个SIA应答,此时,R1通过这个回复知道R1与R3的链路是正常的.通过这种方式有效的避免了SIA的情况.

SIA(陷入主动状态):如果路由器在3分钟(默认时间,主动定时器)内没有收到对查询的应答,路由将陷入主动状态.(SIA)
SIA的常见原因:(使用EIGRP的多个自主系统是无法防止SIA的,因为查询请求会传递到另外一个AS中去.)
EIGRP查询方式是递归.查询路由时发送的是可靠的组播,要求每个邻居能要回应,如果没有回应,它就继续查询.直到SIA(发出查询包后,开启定时器)
1.路由器太忙无法回答查询,CPU过高或是内存不够
2.路由器之间的链路问题,出现丢包.
3.单向链路
SIA的出现,会导致网络上的EIGRP的邻居关系大批量重建,网络瘫痪.
启动EIGRP的邻居日志:eigrp log-neighbor-changes

防止SIA的出现,我们可以限制EIGRP的查询范围.
如何限制EIGRP查询的范围:
1. 使用路由汇总来限制
2. 2.使用末节路由器来限制查询范围
第二: EIGRP的无环路计算和收敛速度是基于分布式的DUAL算法的,这种算法是将不确定的路由信息(active route)散播(向邻居发query报文),得到所有邻居的确认后(reply报文)再收敛的过程,邻居在不确定该路由信息可靠性的情况下又会重复这种散播,因此某些情况下可能会出现该路由信息一直处于active状态,这种路由被称为stuck in active route

EIGRP使用可靠的多播来寻找替代路由.路由器必须得到收到查询的所有路由器的应答才能重新进行计算successor的信息,如果有一个路由器的应该还没有收到的话,发出查询的源路由器就必须等待.默认如果在3分钟内某些路由器没有对应答做出响应的话,这条路由就进入stuck in active(SIA)状态(即始终处于active状态).然后路由器将重新设定和这个没有做出应答的路由器的邻居关系.为了避免SIA情形的发生,解决方案是限制查询的范围.
二十一:RIP IGRP EIGRP OSPF 的度量值是什么?怎么计算出来?
rip管理距离是120,ospf是110,
rip度量值是跳数,而ospf度量值是沿着那条路由所有输出接口的开销
静态路由指定端口管理距离为0,指定IP地址管理距离为1,eigrp90,igrp100,ospf110,rip120,外部eigrp170;
二十二:ospf建立邻居的过程
EIGRP邻居建立过程

1.路由器A启动,然后在链路上发送hello包
2.路由器B接收到A发来的hello包,然后做出应答,发回update包给A,告诉A它自己的路由表的信息.但是这个时候 邻居关系还没有建立直到B发回hello包给A.在B给A的update包里设置了初始位(init bit)的,说明这是初始过程。
3.当双方交换过hello包以后,邻居关系建立.A发回ACK包给B确认它已经收到了从B而来的update包
4.A吸收update包到它自己的topology table中去.topology table包括了从邻居那里得来的所有目的地信息
5.A发送update包给B
6.B收到A发来的update包后做出应答;发回ACK包给A

OSPF邻居建立过程

1.RT1的一个连接到广播类型网络的接口上激活了OSPF协议,并发送了一个HELLO报文(使用组播地址224.0.0.5)。由于此时RT1在该网段中还未发现任何邻居,所以HELLO报文中的Neighbor字段为空。
2.RT2收到RT1发送的HELLO报文后,为RT1创建一个邻居的数据结构。RT2发送一个HELLO报文回应RT1,并且在报文中的Neighbor字段中填入RT1的Router id,表示已收到RT1的HELLO报文,并且将RT1的邻居状态机置为Init。
3.RT1收到RT2回应的HELLO报文后,为RT2创建一个邻居的数据结构,并将邻居状态机置为Exstart状态。下一步双方开始发送各自的链路状态数据库。
为了提高发送的效率,双方需先了解一下对端数据库中那些LSA是自己所需要的(如果某一条LSA自己已经有了,就不再需要请求了)。方法是先发送DD报 文,DD报文中包含了对本地数据库中LSA的摘要描述(每一条摘要可以惟一标识一条LSA,但所占的空间要少得多)。由于OSPF直接用IP报文来封装自 己的协议报文,所以在传输的过程中必须考虑到报文传输的可靠性。为了做到这一点,在DD报文的发送过程中需要确定双方的主从关系。作为Master的一方 定义一个序列号seq,每发送一个新的DD报文将seq 加一。作为Slave的一方,每次发送DD报文时使用接收到的上一个Master的DD报文中的seq。实际上这种序列号机制是一种隐含的确认方法。如果 再加上每个报文都有超时重传,就可以保证这种传输是可靠的。
RT1首先发送一个DD报文,宣称自己是Master(MS=1),并规定序列号为x。I=1表示这是第一个DD报文,报文中并不包含LSA的摘要,只是为了协商主从关系。M=1说明这不是最后一个报文。
4.RT2在收到RT1的DD报文后,将RT1的邻居状态机改为Exstart,并且回应了一个DD报文(该报文中同样不包含LSA的摘要信息)。由于RT2的Router ID较大,所以在报文中RT2认为自己是Master,并且重新规定了序列号为y。
5.RT1收到报文后,同意了RT2为Master,并将RT2的邻居状态机改为Exchange。RT1使用RT2的序列号y来发送新的DD报文,该报文开始正式地传送LSA的摘要。在报文中RT1将MS=0,说明自己是Slave。
6.RT2收到报文后,将RT1的邻居状态机改为Exchange,并发送新的DD报文来描述自己的LSA摘要,需要注意的是:此时RT2已将报文的序列号改为y+1了。
7.上述过程持续进行,RT1通过重复RT2的序列号来确认已收到RT2的报文。RT2通过将序列号+1来确认已收到RT1的报文。当RT2发送最后一个DD报文时,将报文中的M=0,表示这是最后一个DD报文了。
8.RT1收到最后一个DD报文后,发现RT2的数据库中有许多LSA是自己没有的,将邻居状态机改为Loading状态。此时RT2也收到了RT1的最后一个DD报文,但RT1的LSA,RT2都已经有了,不需要再请求,所以直接将RT1的邻居状态机改为Full状态。
9.RT1发送LS Request报文向RT2请求所需要的LSA。RT2用LS Update报文来回应RT1的请求。RT1收到之后,需要发送LS Ack报文来确认。上述过程持续到RT1中的LSA与RT2的LSA完全同步为止。此时RT1将RT2的邻居状态机改为Full状态。
Ospf的dr bdr
DR BDR选取规则: DR BDR选取是以接口状态机的方式触发的.
  1. 路由器的每个多路访问(multi-access)接口都有个路由器优先级(Router Priority),8位长的一个整数,范围是0到255,Cisco路由器默认的优先级是1优先级为0的话将不能选举为DR/BDR.优先级可以通过命令ip ospf priority进行修改.
  2. Hello包里包含了优先级的字段,还包括了可能成为DR/BDR的相关接口的IP地址.
3. 当接口在多路访问网络上初次启动的时候,它把DR/BDR地址设置为0.0.0.0,同时设置等待计时器(wait timer)的值等于路由器无效间隔(Router Dead Interval).。
DR BDR选取过程:
  1. 在和邻居建立双向(2-Way)通信之后,检查邻居的Hello包中Priority,DR和BDR字段,列出所有可以参与DR/BDR选举的邻居.所有的路由器声明它们自己就是DR/BDR(Hello包中DR字段的值就是它们自己的接口地址;BDR字段的值就是它们自己的接口地址)
  2. 从这个有参与选举DR/BDR权的列表中,创建一组没有声明自己就是DR的路由器的子集(声明自己是DR的路由器将不会被选举为BDR)
  3. 如果在这个子集里,不管有没有宣称自己就是BDR,只要在Hello包中BDR字段就等于自己接口的地址,优先级最高的就被选举为BDR;如果优先级都一样,RID最高的选举为BDR
  4. 如果在Hello包中DR字段就等于自己接口的地址,优先级最高的就被选举为DR;如果优先级都一样,RID最高的选举为DR;如果选出的DR不能工作,那么新选举的BDR就成为DR,再重新选举一个BDR。
  5. 要注意的是,当网络中已经选举了DR/BDR后,又出现了1台新的优先级更高的路由器,DR/BDR是不会重新选举的
  6. DR/BDR选举完成后,DRother只和DR/BDR形成邻接关系.所有的路由器将组播Hello包到AllSPFRouters地址224.0.0.5以便它们能跟踪其他邻居的信息,即DR将泛洪update packet到224.0.0.5;DRother只组播update packet到AllDRouter地址224.0.0.6,只有DR/BDR监听这个地址.
  简洁的说:DR的筛选过程
  1.优先级为0的不参与选举
  2.优先级高的路由器为DR
  3.优先级相同时,以router ID 大为DR。
  router ID 以回环接口中最大ip为准。
  若无回环接口,以真实接口最大ip为准。
缺省条件下,优先级为1
登记选民
本网段内的OSPF路由器
本村内的18岁以上公民。 登记候选人
本网段内的priority>0的OSPF路由器;
本村内的30岁以上公民且在本村居住3年以上。
竞选演说
所有的priority>0的OSPF路由器都认为自己是DR;
所有的候选人都自认为应该当村长。
投票
选priority值最大的若priority值相等选Router ID最大的;
选年纪最大若年龄相等按姓氏笔划排序。
DR的选举思想
选举制
DR是各路由器选出来的,而非人工指定的。
终身制
DR一旦当选,除非路由器故障,否则不会更换。
世袭制
DR选出的同时,也选出BDR来。DR故障后,由
BDR接替DR成为新的DR.
Ospf的几种状态机
1.Down:此状态还没有与其他路由器交换信息。首先从其ospf接口向外发送hello分组,还并不知道DR(若为广播网络)和任何其他路由器。发送hello分组是,使用组播地址224.0.0.5。
  2.Attempt: 只适于NBMA网络,在NBMA网络中邻居是手动指定的,在该状态下,路由器将使用HelloInterval取代PollInterval来发 送Hello包.
  3.Init: 表明在DeadInterval里收到了Hello包,但是2-Way通信仍然没有建立起来.
  4.two-way: 双向会话建立,而 RID 彼此出现在对方的邻居列表中。(若为广播网络:例如:以太网。在这个时候应该选举DR,BDR。)
  5.ExStart: 信息交换初始状态,在这个状态下,本地路由器和邻居将建立Master/Slave关系,并确定DD Sequence Number,路由器ID大的的成为Master.
  6.Exchange: 信息交换状态:本地路由器和邻居交换一个或多个DBD分组(也叫DDP) 。DBD包含有关LSDB中LSA条目的摘要信息)。
  7.Loading: 信息加载状态:收到DBD后,使用LSACK分组确认已收到DBD.将收到的信息同LSDB中的信息进行比较。如果DBD中有更新的链路状态条目,则想对方发送一个LSR,用于请求新的LSA 。
  8.Full: 完全邻接状态,这种邻接出现在Router LSA和Network LSA中。
二十四:OSPF邻居不能形成Full关系的常见原因

CCIE 2009-03-23 15:34:03 阅读103 评论0
字号:大中小

以下列出可能的原因,可以逐个排查:
1、该网络根本就没有启动OSPF。接口上没有激活ospf,即在network语句的时候没有匹配清楚,在show

ip ospf interface的时候不会显示希望激活的接口;
2、OSPF邻居的hello及dead interval值不一致;
3、在Stub或NSSA区域,有些路由器没有配置成Stub或NSSA。需要注意,这点是经常被遗忘的;
4、OSPF验证配置错误或不一致;
5、OSPF链路两端的网络类型不一致;
6、OSPF网络类型是NBMA,但没有在OSPF协议模式下配置邻居,观察邻居状态一直处于ATTEMPT状态;
7、OSPF网络类型是NBMA,已配置邻居,但在诸如Frame relay的map语句中没有增加broadcast关键字,导

致协议报文不能到达对方;
8、OSPF Router ID有问题,可能和某个其它路由器配置相同,导致无法确认出Master和Slave;
9、OSPF链路两端的MTU相差比较大,通常停留在EXSTART状态(需要在其接口下配置OSPF忽略MTU检查或修

改MTU);
10、区域号不一致,链路的网络地址不一致,注意检查两边的mask。(PPP协议可以自动协商出地址,

mask不一致也会形成Full关系);
11、建立邻居的接口被passive掉;
12、物理层或者是数据链路层协议down;
13、OSPF的hello组播地址被ACL Block。
二十四:ospf的6种LSA,他们各自包含什么内容,在什么范围内传递
1. 类型1:Router LSA:每个路由器都将产生Router LSA,这种LSA只在本区域内传播,描述了路由器所有的链路和接口,状态和开销.
2. 类型2:Network LSA:在每个多路访问网络中,DR都会产生这种Network LSA,它只在产生这条Network LSA的区域泛洪描述了所有和它相连的路由器(包括DR本身).
3. 类型3:Network Summary LSA :由ABR路由器始发,用于通告该区域外部的目的地址.当其他的路由器收到来自ABR的Network Summary LSA以后,它不会运行SPF算法,它只简单的加上到达那个ABR的开销和Network Summary LSA中包含的开销,通过ABR,到达目标地址的路由和开销一起被加进路由表里,这种依赖中间路由器来确定到达目标地址的完全路由(full route)实际上是距离矢量路由协议的行为
4. 4.类型4:ASBR Summary LSA:由ABR发出,ASBR汇总LSA除了所通告的目的地是一个ASBR而不是一个网络外,其他同NetworkSummary LSA.
5. 类型5:AS External LSA:发自ASBR路由器,用来通告到达OSPF自主系统外部的目的地,或者OSPF自主系统那个外部的缺省路由的LSA.这种LSA将在全AS内泛洪(4个特殊区域除外)
6. 6.类型6:Group Membership LSA
7.   7.类型7:NSSA External LSA:来自非完全Stub区域(not-so-stubby area)内ASBR路由器始发的LSA通告它只在NSSA区域内泛洪,这是与LSA-Type5的区别

【上篇】
【下篇】

给我留言

留言无头像?